WGI in amfori ESG Risk Compass now uses a 0–100 scale; higher scores reflect stronger governance. Four risk levels help identify and prioritise risks. See the guide in the member help centre for details.

Incident Report for amfori

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 11:38 CET

Monitoring

The Worldwide Governance Indicators (WGI) displayed in the amfori ESG Risk Compass have been updated following methodological changes introduced recently by the World Bank. Scores are now expressed on an absolute 0–100 scale, where higher values indicate stronger governance performance. To ensure consistency across indicators in the ESG Risk Compass, WGI results are now mapped to four risk levels (Very High, High, Medium, Low) based on the average score of the six governance dimensions. These risk levels serve as screening signals to help identify potential governance risk hotspots and support prioritisation of further due diligence. For more information, please consult the document dedicated to members available on our website.
The Worldwide Governance Indicators (WGI) in the amfori ESG Risk Compass now use a 0–100 scale, with higher scores showing stronger governance. Results are grouped into four risk levels to help identify and prioritise governance risks.

For details, please see the guide amfori ESG Risk Compass – Worldwide Governance Indicator Guidelines document under the member’s help centre on our website.
Posted Mar 10, 2026 - 12:03 CET
This incident affected: amfori Insights.