When you log in to amfori SustainaPass, you’ll now land on a new guidance page designed to help you navigate your risk assessment and management journey.

Incident Report for amfori

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 11:13 CEST

Monitoring

When you log in to amfori SustainaPass, you’ll now land on a new guidance page designed to help you navigate your risk assessment and management journey. This landing page acts as in‑product expert guidance, helping you understand which route to take based on your organisation’s level of maturity, reducing uncertainty and clarifying next steps.
Posted Apr 07, 2026 - 15:18 CEST
This incident affected: amfori SustainaPass.