Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 12, 2025 - 16:00 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 06, 2025 - 10:11 CET
Scheduled
amfori will be deploying Mandarin and Turkish translations and users that switch to the deployed languages might experience seeing part in the base language English and part in the translation. Limited to 24 hours only during deployment. Our apologies for the inconvenience.
Posted Feb 04, 2025 - 16:43 CET
This scheduled maintenance affected: amfori Sustainability Platform.